I just upgraded to 2.1.21 (or later) and modules don't work

You need modutils-2.1.23 or later. Note that these modutils are incompatible with kernels from 2.1.0 to 2.1.17, so you'll need to keep a copy of modutils-2.1.13 around if you plan on switching back and forth. The sources for modutils can be found at ftp://ftp.redhat.com/pub/alphabits/ or a more reliable mirror, ftp://tsx-11.mit.edu/pub/linux/projects/alphabits/.

If you're running 2.1.26 or later, no patches should be necessary (beyond the ones you had to apply to get that version to compile).

Modules in 2.1 series kernels also require running libc 5.4.17 or later (which in turn requires ld.so 1.8.5 or later). In any event, you probably should be running glibc by now.

Current versions of modutils are available in Debian that support both 2.0 and recent 2.1/2.2 kernels.